P Android won’t support old apps

The app, originally developed using APIs of Android 4.1 and older versions will not be supported on devices running Android P. this is reported by program participants pre-test, obtained access to a first Developer Preview build.

When you try to install on the device the app is incompatible with the new OS, the screen will display the notification with relevant content: “This application was created for an earlier version of Android and may not work correctly. Check for updates or contact the developer.”

At the moment the minimum API version supported by Android P is v17. It corresponds to Android 4.2 Jelly Bean. If a compatibility warning will not disappear in future builds, this may mean that Google has decided to revise in Google Play, freeing up the catalog from legacy applications.

The main reason for the incipient Stripping the app store is something Google to get the Creator to update it in accordance with the new energy efficiency requirements. For example, to add support for the power saving mode Doze of reducing consumption of energy.

To discuss the limitation of the Android P in our official telegram chat.

Leave a Reply

Your email address will not be published. Required fields are marked *